anomy-list

logs of filtered HTML inline and HTML tags showing up at top of message after updating to 1.74

From: Noel Clarkson (142343@xyz.molar.is)
Date: Tue 23 Aug 2005 - 03:06:14 GMT


Hi All,

we've recently updated to 1.74 and enabled html scanning. This is working
well from the scanning end, but the log files are showing up at the end of
the messages inline instead of as attachments. Works great if I put an exe
on it, log file in attachment, but the html ones end up with sometimes pages
of logs after them which is annoying to people when they go to print the
email out.

I've looked at various of the config options, and have turned logging off
and on etc, but can't seem to work out how to get the logs into an
attachment in the html case.

The other problem that we are seeing from some people is that they get a
bunch of html header sort of stuff before they get the actual message. For
example here is some of the stuff from one of the messages:

@font-face { font-family: Verdana; } @font-face { font-family: Papyrus; }
@page Section1 {size: 595.3pt 841.9pt; margin: 72.0pt 90.0pt 72.0pt 90.0pt;
} P.MsoNormal { FONT-SIZE: 12pt; MARGIN: 0cm 0cm 0pt; COLOR: black;
FONT-FAMILY: "Times New Roman" } LI.MsoNormal { FONT-SIZE: 12pt; MARGIN: 0cm
0cm 0pt; COLOR: black; FONT-FAMILY: "Times New Roman" } DIV.MsoNormal {
FONT-SIZE: 12pt; MARGIN: 0cm 0cm 0pt; COLOR: black; FONT-FAMILY: "Times New
Roman" } A:link { COLOR: #339933; TEXT-DECORATION: underline }
SPAN.MsoHyperlink { COLOR: #339933; TEXT-DECORATION: underline } A:visited {
COLOR: #339933; TEXT-DECORATION: underline } SPAN.MsoHyperlinkFollowed {
COLOR: #339933; TEXT-DECORATION: underline } ADDRESS { FONT-SIZE: 12pt;
MARGIN: 0cm 0cm 0pt; COLOR: black; FONT-FAMILY: "Times New Roman" } P.vrb9 {
FONT-SIZE: 7pt; MARGIN-LEFT: 0cm; MARGIN-RIGHT: 0cm; mso-margin-top-alt:
auto; mso-margin-bottom-alt: auto } LI.vrb9 { FONT-SIZE: 7pt; MARGIN-LEFT:
0cm; MARGIN-RIGHT: 0cm;

This seems to only have started happening since the update (we were on
version 1.34) and I'm not sure where to start in trying to diagnose what
might be causing it. I'm happy to get it in pre sanitized and sanitized
versions, compare etc, but I'm not ever sure which bits I should be focusing
on.

Any thoughts on either of these two problems would be great.

cheers,

noel.



hosted by molar.is