anomy-list

Anomy bouncing messages "Message content rejected"

From: Sean Carney (130891@xyz.molar.is)
Date: Fri 09 Jul 2004 - 21:56:48 GMT

  • Next message: Paolo: "Re: Anomy bouncing messages "Message content rejected""

    Hi everyone, new guy on the list :)

    I'm running Anomy 1.68 and Spamassasin with Postfix using the Advosys
    method. I want to say that it's saved me a lot of headaches, it's usually
    a great bit of software. Usually. :) It started bouncing all messages
    that come in with attachments to any of the domains I have it set to
    filter, trusted attachment or not, it didn't matter. Messages without
    attachments went through fine.

    The offending maillog line I'm getting is this:

    Jul 8 15:51:12 argon postfix/pipe[27986]: 3E9A1613:
    to=<130981@xyz.molar.is>, orig_to=<131020@xyz.molar.is>,
    relay=filter, delay=4, status=bounced (service unavailable. Command
    output: Message content rejected )

    The anomy log is telling me this:

    Can't use an undefined value as a symbol reference at
    /usr/local/anomy/bin/Anomy/Sanitizer.pm line 1076.

    And you can take a peek at my anomy.conf file at
    http://207.30.5.177/~sean/anomy.conf

    Anyone have any suggestions? It started happening about three days ago.
    I upgraded to Anomy 1.68 a few weeks ago, but it's worked perfectly since
    then, till a few days ago. I haven't made any changes to the system
    lately, haven't installed any new software, etc. Rolling it back to ver
    1.67 wouldn't be hard, but I don't know if that's actually the problem.
    It's a slackware 9.1 system if that helps. Let me know if anyone needs
    anymore info. Any help will be appreciated. Thanks,

    Sean Carney
    Systems Administrator
    Liberty Communications



    hosted by molar.is