anomy-list

Re: Anomy won't run on Redhat 9, Perl 5.8

From: Rick Johnson (79840@xyz.molar.is)
Date: Fri 16 May 2003 - 14:26:13 GMT

  • Next message: Robert Gabriel: "Postfix incoming mail only..."

    I'll vouch as well that this works for me as I'm running Sanitizer on
    Sendmail (with SpamAssassin) under Red Hat 9 with Perl 5.8.0. The UTF-8
    addition has been there since Red Hat 8.0, however.

    Red Hat's position on the bug (from BugZilla) is that it isn't a bug, but
    rather other applications poorly support UTF8, and need to be fixed in order
    to "move forward".

    -Rick

    On 05/16/2003 12:30 AM, 79929@xyz.molar.is wrote:
    > I know that this has been discussed here before, and the issues are
    > caused by the same character set issues that cause compiles to fail on
    > SpamAssassin, et al.
    > It seems specific to Perl 5.8.0 and RH 9 for now.
    >
    >
    >
    > For a fix, you could "export LANG=en_US" before trying the tests, or
    > better, edit /etc/sysconfig/i18n to look like:
    >
    >
    >
    > LANG="en_US"
    > SUPPORTED="en_US:en"
    > SYSFONT="lat0-sun16"
    > SYSFONTACM="iso01"
    >
    >
    >
    > for a more permanent solution.
    >
    > YMMV, but once I got rid of all of that utf8 stuff, all of my perl
    > problems with RH9 disappeared.
    >
    >
    >
    > Anyway, this is not my solution, I just got it off google groups, but
    > I cannot find the particular thread where I first saw this answer (its
    > in many though).
    > You will note that this will also make CPAN work again. Without this
    > fix, "install Bundle::CPAN" will fail on compile, as well as Net::CMD,
    > Mail::SpamAssassin, and Digest::MD5, although surprisingly,
    > Digest::SHA1 compiled just fine before I found out this fix.
    >
    > -----Ryan van Rensburg <79970@xyz.molar.is> wrote: -----
    > To: Kunal Rupera <80008@xyz.molar.is>
    > From: Ryan van Rensburg <79970@xyz.molar.is>
    > Date: 05/16/2003 02:13AM
    > cc: 79879@xyz.molar.is
    > Subject: Re: [anomy-list]: Anomy won't run on Redhat 9, Perl 5.8
    > Hi
    > Have attached my results.def folder and results.txt says wich ones fai
    > led.
    > Thanks
    > Kunal Rupera wrote:
    > >i run anomy safely with postfix on redhat 9 for my mail server.
    > >
    > >Kunal
    > >
    > >btw can u just paste ur errors so that we know what deps are failed ?
    >
    > >
    > >-------- Original Message --------
    > >
    > >==> From: Ryan van Rensburg <79970@xyz.molar.is>
    > >==> Date: Fri, 16 May 2003 07:37:40 0200
    > >
    > >Hi All
    > >
    > >Desperately need to go live with a new server, the only thing is that
    > >I can't get any of the testcases to succeed. The pre-requisites are
    > >there. I saw the problem being experienced by some with 2 of the test
    > >cases failing with Perl 5.8, in my case all of them fail. Is there a
    > >way to get it running on a previous version of Perl and if so how?
    > >
    > >Running Redhat 9, Sanitizer 1.59, Perl 5.8.
    > >
    > >Many Thanks
    > >
    > >-- Ryan van Rensburg IT Support Manager Intoweb Design
    > >http://www.intoweb.co.za Tel: 27 12 348 5320 Fax: 27 12 361 5576
    > >
    > >
    > >
    >
    > Attachments:
    > + http://mailtools.anomy.net/archives/anomy-list//18/ba/3ec493b9/00.unnamed.html
    >

    -- 
    Rick Johnson, RHCE #807302311706007 - 79840@xyz.molar.is
    Linux/Network Administrator - Medata, Inc. (from home)
    PGP Public Key: https://mail.medata.com/pgp/rjohnson.asc
    



    hosted by molar.is