anomy-list

Re: problem with anomy 1.45

From: Bjarni R. Einarsson (27277@xyz.molar.is)
Date: Tue 18 Dec 2001 - 00:03:55 UTC

  • Next message: Dave Cridland: "Re: LMTP level filtering helper script"

    On 2001-12-14, 10:47:00 (-0700), alex morris wrote:
    > On a RH Linux 6.2 system, perl version 5.005, all anomy-required perl
    > modules installed and visible, I attempt to test the new 1.45 sanitizer
    > by invoking it manually.
    ...
    > Can't call method "entry" on an undefined value at
    > /usr/lib/perl5/site_perl/5.005/i386-linux/Anomy/Sanitizer.pm line 688.
    ...
    > More than likely, I have dorked my config somewhere, but I can't figure
    > out how.. Any suggestions are welcome.

    The Anomy configuration file almost certainly has nothing to do with
    this problem.

    On the other hand, the location of modules (e.g. older versions
    being used by accident) could cause this. This is exactly the type
    of error I'd expect to see if you were using an old version of
    MIMEStream.pm with a new Sanitizer.pm.

    Did the test cases run OK?

    -- 
    Bjarni R. Einarsson                           PGP: 02764305, B7A3AB89
     27277@xyz.molar.is                -><-              http://bre.klaki.net/
    

    Check out my open-source email sanitizer: http://mailtools.anomy.net/



    hosted by molar.is