anomy-bugs

Sanitizer Hangs

From: Holger Kunst (25662@xyz.molar.is)
Date: Sat 14 Jun 2003 - 18:45:01 GMT

  • Next message: Rick Troxel: "Solaris tweaks for testcases"

    Hi,

    I am using Anomy Sanitizer 1.60 and encountered three similar messages
    which causes it to hang. It has worked fine with thousands of other
    messages. The attachments of the messages in question contain malware and I
    can't attach them here. But if you need to look at them you can download
    them here: http://mail.truebridge.com/message.zip

    Configuration:
    -Anomy Sanitizer 1.60
    -FreeBSD 4.7
    -version 5.005_03 built for i386-freebsd

    Here's how I call the sanitizer to reproduce the problem:
    cat msg498 | (export ANOMY=/usr/local/anomy;
    /usr/local/anomy/bin/sanitizer.pl /usr/local/etc/anomy.cfg)

    anomy.cfg:
    feat_webbugs = 1 # Web-bugs are not allowed.

    The test cases also report problems (diff files attached)
    sanitizer.base64: failed (moved result files to results.def)
    let: arith: syntax error: "FAILED=0+1"

    sanitizer.defaults: failed (moved result files to results.def)
    let: arith: syntax error: "FAILED=0+1"

    sanitizer.filenames: failed (moved result files to results.def)
    let: arith: syntax error: "FAILED=0+1"

    sanitizer.rev1_60: failed (moved result files to results.def)
    let: arith: syntax error: "FAILED=0+1"

    Is my problem related to the failed test cases? Any Suggestions on how to
    get the tests running OK?

    Thanks

    Holger

    Attachments:
     + http://mailtools.anomy.net/archives/anomy-bugs//1d/9d/3eeb6d5b/01.testcases.zip



    hosted by molar.is